Parches de seguridad para productos Apple

Apple ha lanzado un parche de seguridad para sus productos iOS, iPadOS, macOS, tvOS y watchOS que corrige varios errores de seguridad.

Las vulnerabilidades afectan a los productos Safari 15.6, watchOS 8.7, Security Update 2022-005 Catalina, macOS Big Sur 11.6.8, macOS Monterey 12.5, tvOS 15.6 y iOS 15.6 and iPadOS 15.6.

Las vulnerabilidades corregidas son las que se detallan a continuación:

CVE-2022-32832. Un error en APFS en el manejo de la memoria que podría permitir a una aplicación con privilegios de root la ejecución de código arbitrario con privilegios de kernel.

CVE-2022-32788. Un desbordamiento de memoria en AppleAVD que podría permitir la ejecución de código arbitrario.

CVE-2022-32824. Un error en el manejo de memoria en AppleAVD que podría revelar información sensible del kernel.

CVE-2022-32826. Un error en AppMobileFileIntegrity en el manejador de estados podría permitir la elevación de privilegios a un aplicación.

CVE-2022-32810 y CVE-2022-32840. Varios errores en el manejo de memoria en AppleNeuralEngine que podría permitir la ejecución de código arbitrario con privilegios de kernel.

CVE-2022-32845. Un error de validación en Apple Neural Engine que podría permitir saltar restricciones de seguridad.

CVE-2022-32797. Un error en AppleScript al verificar los direccionamientos que podría revelar información sensible de los procesos en memoria a traves de un script AppleScript especialmente manipulado.

CVE-2022-32853, CVE-2022-32852 y CVE-2022-32851. Varios errores de fuera de límites en AppleScript al procesar datos de entrada que podría revelar información sensible de los procesos en memoria a traves de un script AppleScript especialmente manipulado.

CVE-2022-32831. Un error en AppleScript de fuera de límites al direcionar de forma incorrecta los límites y que podría revelar información sensible de los procesos en memoria a traves de un script AppleScript especialmente manipulado.

CVE-2022-32825. Un error en Audio al controlar la memoria que podría revelar información sensible en la memoria del kernel.

CVE-2022-32820. Un error de fuera de límites en Audio al procesar datos de entrada que podría revelar información sensible de los procesos en memoria a través de una aplicación especialmente manipulada.

CVE-2022-32805. Un error en el manejo de cachés en Calendar que popdría revelar información sensible a través de una aplicación especialmente manipulada.

CVE-2022-32849. Un error en Calendar podría revelar información sensible del usuario a través de una aplicación especialmente manipulada.

CVE-2022-32828. Un error al manejar la memoria en CoreMedia que podría revelar información sensible en el espacio del kernel.

CVE-2022-32839. Un error en la validación de límites en Coretext que podría permitir a un usuario remoto la ejecución de código arbitrario a través de una aplicacion especialmente manipulada.

CVE-2022-32781. Un error en FaceTime podría permitir a una aplicación con privilegios de root la revelación de información sensible.

CVE-2022-32819. Un error de lógica en el manejo de estados en File System Events que podría permitir a una aplicación elevar privilegios de seguridad.

CVE-2022-32793. Un error de limites en GPU Drivers que podría revelar información sensible en el espacio del kernel.

CVE-2022-32821. Un error de corrupción de memoria en GPU Drivers que podría ejecutar dódigo arbitrario con permisos del kernel.

CVE-2022-32855. Un error de lógica al manejar los estados en Home podría permitir saltar restricciones de seguridad.

CVE-2022-32849. Un error en iCloud Photo Library que podría permir revelar información sensible.

CVE-2022-32787. Un error de fuera de límites en ICU que podria permitir la ejecución de código arbitrario a través de una página web especialmente manipulada.

CVE-2022-32785. Un error de referecia de puntero nulo en ImageIO que podría causar una denegación de servicio.

CVE-2022-32802. Un error de chequeo en ImageIO que podría ejecutar código arbitrario.

CVE-2022-32841 y CVE-2022-32830. Varios errores en el manejo de la memoria en ImageIO que podría revelar información sensible.

CVE-2022-26768. Un error de corrupción de memoria en IOMobileFrameBuffer que podría permitir la ejecución de código arbitrario con privilegios de kernel.

CVE-2022-32812 y CVE-2022-32811. Un error al manejar la memoria en Intel Graphics Driver que podría permitir la ajecución de código con privilegios de kernel.

CVE-2022-32815, CVE-2022-32817, CVE-2022-32844, CVE-2022-32829 y CVE-2022-32813. Varios errores al manejar la memoria en el kernel podría permitir la ejecución de código arbitrario con permisos de kernel.

CVE-2022-26981. Un error de checqueo en Liblouis podría ejecutar código arbitrario.

CVE-2022-32823. Un error al inicializar memoria en libxml2 podría revelar información sensible.

CVE-2022-32814. Un error de confusion de tipo en Multi-Touch podría permitir la ejecución de código arbitrario.

CVE-2022-32786 y CVE-2022-32800. Un error en PackageKit al manejar las variable de entorno que podría permitir la escritura en ficheros protegidos.

CVE-2022-32838. Un error de lógica en el manejo de estados en PluginKit que podría permitir a una aplicación la lectura de ficheors arbitrarios.

CVE-2022-32843. Un error de control de límites en PS Normalizer que podría revelar información sensible a través de un fichero Postscript especialmente manipulado.

CVE-2022-32796. Un error de corrupción de memoria en SMB que podría permitir la ejecución de código arbitrario con privilegios de kernel.

CVE-2022-32842 y CVE-2022-32798. Un error de límites en SMB que podría permitir una elevación de privilegios.

CVE-2022-32799 y CVE-2022-32818. Varios errores en límites en SMB podría revelar información sensible.

CVE-2022-32784. Un error al manejar el UI en Safari Extensions que podría permitir revelar información sensible.

CVE-2022-32857. Un error en Software Update al enviar información sobre HTTPS que podría permitir a un usuario de la red el trackear actividad de otros usuarios.

CVE-2022-32807. Un error en al manejar ficheros en Spindump que podría permitir a una aplicación la sobreescritura de ficheros.

CVE-2022-26704. Un error de valicación en Spotlight que podría elevar privilegios de seguridad.

CVE-2021-28544, CVE-2022-24070, CVE-2022-29046 y CVE-2022-29048. Varios errores en subversion al actualizarlo que podría causar múltiples impactos.

CVE-2022-32834. Un error de acceso en TCC que podría permitir información sensible a través de una aplicación especialmente manipulada.

CVE-2022-0156 y CVE-2022-0158. Un error en Vim al actualizarlo podría causar múltiples errores.

CVE-2022-32816 y CVE-2022-32792. Varios errores en el manejo de UI en WebKit que podría permitir la ejecución de código arbitrario a traves de una página web especialmente manipulada.

CVE-2022-2294. Un error de corrupción de mermoria en WebRTC que podría permitir la ejecución de código arbitrario a través de una pagina web especialmente manipulada.

CVE-2022-32837 y CVE-2022-32847. Varios errores de validación en Wi-Fi podría corromper la memoria y causar una denegación de servicio.

CVE-2022-32848. Un error de chequeo en Windows Server podría permitir a una aplicación la realización de capturas.

El número de vulnerabilidades corregidas es elevado por lo que se recomienda actualizar a todos los usuarios lo antes posible. Las actualizaciones de seguridad proporcionadas por los fabricantes deberían ser una prioridad para todos los usuarios en el momento en que son liberadas ya que las vulnerabilidades sin corregir pueden ser explotadas con fines maliciosos quedando expuestos a ataques de diversos tipos.

Más información:

* Apple security updates
https://support.apple.com/en-us/HT201222

La entrada Parches de seguridad para productos Apple se publicó primero en Una al Día.